Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Mannis Diva 0.9.1.1.45
#1
Diva Test mit OpenSim 0.9.1.1.37 Dev als Release kompiliert.
Das ist nicht die Original Diva Version, diese ist von mir.
Kompiliert und getestet am 9.11.2019 für mono 4.6, diva ist hierfür umgebaut von mir.
Benutzung auf eigene gefahr.

   

https://www.mediafire.com/file/waasdk8pr1br5sq/Mdiva-r091116.zip/file

http://www.mediafire.com/file/uydwt4s2y5eurtl/mdiva-r091137.zip/file

https://www.mediafire.com/file/1o8nifgs7...5.zip/file



Bekannte Fehler:
Durch das veraltete Email System von diva wurden mir 2 Warnungen beim kompilieren ausgegeben.

Build succeeded.

"/opt/diva-r091137/OpenSim.sln" (default target) (1) ->
"/opt/diva-r091137/addon-modules/21Wifi/Diva.Wifi.csproj" (default target) (32) ->
(CoreCompile target) ->
  WebApp/Services.cs(74,17): warning CS0618: 'SmtpClient' is obsolete: 'SmtpClient and its network of types are poorly designed, we strongly recommend you use https://github.com/jstedfast/MailKit and https://github.com/jstedfast/MimeKit instead' [/opt/diva-r091137/addon-modules/21Wifi/Diva.Wifi.csproj]
  WebApp/Services.cs(124,28): warning CS0618: 'SmtpClient' is obsolete: 'SmtpClient and its network of types are poorly designed, we strongly recommend you use https://github.com/jstedfast/MailKit and https://github.com/jstedfast/MimeKit instead' [/opt/diva-r091137/addon-modules/21Wifi/Diva.Wifi.csproj]

    2 Warning(s)
    0 Error(s)
- Beipackzettel: Kann Spuren von persönlichen Meinungen, Sarkasmus und Ironie enthalten.
Ausdrücke sind nicht für den Verkehr geeignet. Gelesen mindestens haltbar, siehe oben. -
Antworten }
Thanks given by: wavefan , Achim
#2
(09.11.2019, 18:56)Manni schrieb: Diva Test mit OpenSim 0.9.1.1.16 Dev als Release kompiliert.
Setze diese auch ein. Also Diva mit Wifi.
Warum nicht Mono 6.4, läuft bei mir ohne Probleme und gefühlt auch schneller.
Antworten }
Thanks given by: Achim
#3
Diva benötigt mono 4.0 ich habe dies angeglichen an OpenSim dieser benötigt 4.6.
Ergebnis ist der Compiler meckert wegen EMail wäre unsicher, aber solange der nur meckert ist mir das egal, denn das zu ändern ist nicht leicht und sehr umfangreich.
- Beipackzettel: Kann Spuren von persönlichen Meinungen, Sarkasmus und Ironie enthalten.
Ausdrücke sind nicht für den Verkehr geeignet. Gelesen mindestens haltbar, siehe oben. -
Antworten }
Thanks given by:
#4
Hallo Manni,

im Mono Bereich sind wir mittlerweile bei mind. 5.18
---------
DarkWolf

Virtual Life Grid


Lebe dein Leben - lebe es, denn es ist Deins

Was zum nachdenken für SIM Betreiber

"Ist es Kunst - oder kann es weg?
(Zitat Josch Wolf)
Antworten }
Thanks given by: Achim
#5
Das ist die Mindestanforderung von mono, ich nutze selbstverständlich immer das neuste mono.
- Beipackzettel: Kann Spuren von persönlichen Meinungen, Sarkasmus und Ironie enthalten.
Ausdrücke sind nicht für den Verkehr geeignet. Gelesen mindestens haltbar, siehe oben. -
Antworten }
Thanks given by:
#6
mdiva-r091137 DEV Test
https://www.mediafire.com/file/uydwt4s2y5eurtl/mdiva-r091137.zip/file

mdiva basiert auf OpenSimulator 0.9.1.1 Dev 37 und ist auf einem Tagesaktuellen Ubuntu 19 Server mit neustem mono  kompiliert worden.
Ich verwende nur OpenSimulator Master Versionen keine git clone, dann auch nur wenn sie in meinem Grid getestet wurden.
Diva ist mit Visual Studio 2019 unter Windows 10 bearbeitet und bis auf Smtp angepasst worden an OS0.9.1.1,
veraltete und/oder nicht mehr verwendete teile sind entfernt worden.


Zitat:Build succeeded.

"/opt/diva-r091137/OpenSim.sln" (default target) (1) ->
"/opt/diva-r091137/addon-modules/21Wifi/Diva.Wifi.csproj" (default target) (32) ->
(CoreCompile target) ->
 WebApp/Services.cs(74,17): warning CS0618: 'SmtpClient' is obsolete: 'SmtpClient and its network of types are poorly designed, we strongly recommend you use https://github.com/jstedfast/MailKit and https://github.com/jstedfast/MimeKit instead' [/opt/diva-r091137/addon-modules/21Wifi/Diva.Wifi.csproj]
 WebApp/Services.cs(124,28): warning CS0618: 'SmtpClient' is obsolete: 'SmtpClient and its network of types are poorly designed, we strongly recommend you use https://github.com/jstedfast/MailKit and https://github.com/jstedfast/MimeKit instead' [/opt/diva-r091137/addon-modules/21Wifi/Diva.Wifi.csproj]

   2 Warning(s)
   0 Error(s)



Test: Läuft sehr gut.

Installation:
Herunterladen und entpacken.

Windows
Starte "Configure.exe" und folge den Anweisungen.
Starte "OpenSim.exe"
fertig viel Spaß.

Linux
Starte "mono Configure.exe" und folge den Anweisungen.
Starte "mono OpenSim.exe"
fertig viel Spaß.

Configure kann so oft wiederholt werden wie ihr möchtet.


Name of your world: NameMeinerNeuenWelt

MySql database host: [localhost] einfach Enter/Return drücken.

MySql database schema name: [opensim] Name eurer mySQL Datenbank.

MySql database user account: [opensim] Benutzername eurer mySQL Datenbank.

MySql database password for that account: Passwort eurer mySQL Datenbank.

Your external domain name (preferred) or IP address: meinserver.de oder 127.0.0.1 ohne http (Bitte nutzt eure adresse oder IP).

This installation is going to run on
[1] .NET/Windows
[2] *ix/Mono
Choose 1 or 2 [1]: läuft es auf Windows dann drückt 1, läuft es auf Linux dann drückt bitte 2.

Wifi Benutzername, Passwort und EMail der nun folgt sollte nicht euer Inworld Avatar sein.

User account creation [o]pen or [c]ontrolled [c]: Dürfen sich andere Registrieren?

Gmail ist für controlled accounts hier kann man auch einfach alles mit Enter/Return überspringen.

Nach der Installation wird euch noch die Login und Einwahladressen mitgeteilt diese solltet ihr euch kopieren.

Nach dem Start von OpenSim könnt ihr euch mit eurer loginuri mit jedem OpenSim fähigen Viewer einwählen.


Zitat:Manche Funktionen im Wifi Webinterface verlangen nach der Fernsteuerung über Rest-Console.
So wird OpenSim dann gestartet.
Windows:
OpenSim.exe -console rest
Linux:
mono OpenSim.exe -console rest


ACHTUNG: Diva nutzt nur eine Datenbank und diese reicht für eine 512x512 oder 4 Stück 256x256 Regionen.

   
- Beipackzettel: Kann Spuren von persönlichen Meinungen, Sarkasmus und Ironie enthalten.
Ausdrücke sind nicht für den Verkehr geeignet. Gelesen mindestens haltbar, siehe oben. -
Antworten }
Thanks given by:
#7
Kann ich das auf meinem Windows PC verwenden?


Diva ist eine Standalone Hypergrid Version von OpenSim mit der du schon ein fertiges Webinterface und Zugang zu allen offenen Grid´s hast (Halt wie ein richtiges Grid).
Du brauchst eigentlich nur xampp installieren, das stellt dir einen Web und einen mySQL Server unter Windows zur Verfügung.
Du brauchst also nur xampp starten.
Dort aktivierst du apache und mySQL.
Dann neben mySQL auf Admin drücken, hier erstellst du dir eine mySQL Datenbank mit dem Namen Beispiel: opensim.
xampp nutzt kein Passwort, deswegen musst du auch das Passwort beim konfigurieren ( Configure.exe ) leer lassen.
Wenn du fertig bist brauchst du nur noch OpenSim starten und du bist mit allen Vorzügen eines eigenen Grid´s dazu fähig in deinem oder fremden Grid´s alles zu tun was du magst.

xampp Seite mit kostenlosen Downloads:
https://www.apachefriends.org/de/index.html

Wenn xampp einmal installiert ist und man ein wenig Übung hat,
lässt sich OpenSim in wenigen Augenblicken durch entpacken und Konfigurieren in unter 3 Minuten neu erstellen.
Hiermit ist es auch das ultimative Experimentier-Werkzeug.
- Beipackzettel: Kann Spuren von persönlichen Meinungen, Sarkasmus und Ironie enthalten.
Ausdrücke sind nicht für den Verkehr geeignet. Gelesen mindestens haltbar, siehe oben. -
Antworten }
Thanks given by:
#8
Mdiva-r091145
Dev Test - diva clone

Überarbeitet:
mdiva-distribution-master
OpenSim.ini
DivaPreferences.ini

Download Binary:
https://www.mediafire.com/file/1o8nifgs7...5.zip/file

Source:
https://github.com/BigManzai/diva-distribution

Status:
disabled CS0618
Build succeeded.
Code:
0 Warning(s)
0 Error(s)
- Beipackzettel: Kann Spuren von persönlichen Meinungen, Sarkasmus und Ironie enthalten.
Ausdrücke sind nicht für den Verkehr geeignet. Gelesen mindestens haltbar, siehe oben. -
Antworten }
Thanks given by:
#9
Wer Money in sein OpenSimulator verwenden möchte,
der muss die Source Datei BaseHttpServer.cs Patchen wie es in der Anleitung zu opensim.currency-0.9.1 steht.
Wer das nicht kann und meine OpenSim Version OpenSim 0.9.1.1 oder mdiva 0.9.1.1 verwendet,
kann die angehängten Dateien in den Ordner OpenSim/bin kopieren.

Bitte vergesst nicht vorher eure alten Dateien sicherheitshalber zu sichern.

Auf der Homepage von Network System Laboratory of TUIS
http://www.nsl.tuis.ac.jp/xoops/modules/...oneyServer
bekommt unter tar Ball - 0.9.1 for OpenSim-0.9.1 alle weiteren Dateien um einen Money Server laufen zu lassen.


Angehängte Dateien
.zip   opensim-money-0912.zip (Größe: 84,2 KB / Downloads: 10)
- Beipackzettel: Kann Spuren von persönlichen Meinungen, Sarkasmus und Ironie enthalten.
Ausdrücke sind nicht für den Verkehr geeignet. Gelesen mindestens haltbar, siehe oben. -
Antworten }
Thanks given by:


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste